summaryrefslogtreecommitdiffstats
path: root/openshift-ansible.spec
diff options
context:
space:
mode:
authorJoel Diaz <jdiaz@redhat.com>2016-03-07 12:08:10 -0500
committerJoel Diaz <jdiaz@redhat.com>2016-03-07 12:08:10 -0500
commit30b0cf981169ae7f74c767cda00a51a39f35b434 (patch)
tree330463b6f201104d845bdc478d7a7db4a2e74821 /openshift-ansible.spec
parentcb04158b51d8ccf726c18551e6a1af5e136988d8 (diff)
parentc3fd0343bc32046043715e7d7fdddd2804639f8e (diff)
downloadopenshift-30b0cf981169ae7f74c767cda00a51a39f35b434.tar.gz
openshift-30b0cf981169ae7f74c767cda00a51a39f35b434.tar.bz2
openshift-30b0cf981169ae7f74c767cda00a51a39f35b434.tar.xz
openshift-30b0cf981169ae7f74c767cda00a51a39f35b434.zip
Merge pull request #1539 from joelddiaz/ansible-zabbix-rpm
package up lib_zabbix into its own subpackage
Diffstat (limited to 'openshift-ansible.spec')
-rw-r--r--openshift-ansible.spec18
1 files changed, 18 insertions, 0 deletions
diff --git a/openshift-ansible.spec b/openshift-ansible.spec
index 9d0a18541..693bdc39f 100644
--- a/openshift-ansible.spec
+++ b/openshift-ansible.spec
@@ -74,6 +74,10 @@ cp -rp playbooks %{buildroot}%{_datadir}/ansible/%{name}/
# openshift-ansible-roles install
cp -rp roles %{buildroot}%{_datadir}/ansible/%{name}/
+# openshift-ansible-zabbix install (standalone lib_zabbix library)
+mkdir -p %{buildroot}%{_datadir}/ansible/zabbix
+cp -rp roles/lib_zabbix/library/* %{buildroot}%{_datadir}/ansible/zabbix/
+
# openshift-ansible-filter-plugins install
cp -rp filter_plugins %{buildroot}%{_datadir}/ansible_plugins/
@@ -117,6 +121,20 @@ Scripts to make it nicer when working with hosts that are defined only by metada
# ----------------------------------------------------------------------------------
+# openshift-ansible-zabbix subpackage
+# ----------------------------------------------------------------------------------
+%package zabbix
+Summary: Openshift and Atomic Enterprise Ansible Zabbix library
+Requires: python-openshift-tools-zbxapi
+BuildArch: noarch
+
+%description zabbix
+Python library for interacting with Zabbix with Ansible.
+
+%files zabbix
+%{_datadir}/ansible/zabbix
+
+# ----------------------------------------------------------------------------------
# openshift-ansible-docs subpackage
# ----------------------------------------------------------------------------------
%package docs