summaryrefslogtreecommitdiffstats
path: root/openshift-ansible.spec
diff options
context:
space:
mode:
authorJoel Diaz <jdiaz@redhat.com>2016-02-12 16:44:36 -0500
committerJoel Diaz <jdiaz@redhat.com>2016-03-03 15:40:39 -0500
commitc3fd0343bc32046043715e7d7fdddd2804639f8e (patch)
treee8ce4d96f4b0d53efd941eabc1c58ef0cd6d5d51 /openshift-ansible.spec
parent9160b641b79f08fb28976b7f0ceed62dcea8f9a8 (diff)
downloadopenshift-c3fd0343bc32046043715e7d7fdddd2804639f8e.tar.gz
openshift-c3fd0343bc32046043715e7d7fdddd2804639f8e.tar.bz2
openshift-c3fd0343bc32046043715e7d7fdddd2804639f8e.tar.xz
openshift-c3fd0343bc32046043715e7d7fdddd2804639f8e.zip
package up lib_zabbix into its own subpackage
Diffstat (limited to 'openshift-ansible.spec')
-rw-r--r--openshift-ansible.spec18
1 files changed, 18 insertions, 0 deletions
diff --git a/openshift-ansible.spec b/openshift-ansible.spec
index 7c7fb399c..b8ec1be5d 100644
--- a/openshift-ansible.spec
+++ b/openshift-ansible.spec
@@ -72,6 +72,10 @@ cp -rp playbooks %{buildroot}%{_datadir}/ansible/%{name}/
# openshift-ansible-roles install
cp -rp roles %{buildroot}%{_datadir}/ansible/%{name}/
+# openshift-ansible-zabbix install (standalone lib_zabbix library)
+mkdir -p %{buildroot}%{_datadir}/ansible/zabbix
+cp -rp roles/lib_zabbix/library/* %{buildroot}%{_datadir}/ansible/zabbix/
+
# openshift-ansible-filter-plugins install
cp -rp filter_plugins %{buildroot}%{_datadir}/ansible_plugins/
@@ -115,6 +119,20 @@ Scripts to make it nicer when working with hosts that are defined only by metada
# ----------------------------------------------------------------------------------
+# openshift-ansible-zabbix subpackage
+# ----------------------------------------------------------------------------------
+%package zabbix
+Summary: Openshift and Atomic Enterprise Ansible Zabbix library
+Requires: python-openshift-tools-zbxapi
+BuildArch: noarch
+
+%description zabbix
+Python library for interacting with Zabbix with Ansible.
+
+%files zabbix
+%{_datadir}/ansible/zabbix
+
+# ----------------------------------------------------------------------------------
# openshift-ansible-docs subpackage
# ----------------------------------------------------------------------------------
%package docs