summaryrefslogtreecommitdiffstats
path: root/setup.cfg
diff options
context:
space:
mode:
authorJason DeTiberus <jdetiber@redhat.com>2016-12-21 17:15:42 -0500
committerJason DeTiberus <jdetiber@redhat.com>2017-01-10 11:45:30 -0500
commitbe949e0a0a2420205aaf80de514432a76596a854 (patch)
treebe5edc6198f976215c1521a490d788f46b29e227 /setup.cfg
parent9d316d3091b28820e3840c535fc9bc4b6603ed72 (diff)
downloadopenshift-be949e0a0a2420205aaf80de514432a76596a854.tar.gz
openshift-be949e0a0a2420205aaf80de514432a76596a854.tar.bz2
openshift-be949e0a0a2420205aaf80de514432a76596a854.tar.xz
openshift-be949e0a0a2420205aaf80de514432a76596a854.zip
More toxification
- Move pylint tests to tox - Move yamllint tests to tox - Create separate tox config (and setup.py) for root - bump ansible requirement - unify pylint config - add docs - remove git directory containing old testing tools - install python-six if not present for openshift-facts - add python-six as a dependency for openshift-ansible-utils
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg27
1 files changed, 27 insertions, 0 deletions
diff --git a/setup.cfg b/setup.cfg
new file mode 100644
index 000000000..d55df9d37
--- /dev/null
+++ b/setup.cfg
@@ -0,0 +1,27 @@
+[bdist_wheel]
+# This flag says that the code is written to work on both Python 2 and Python
+# 3. If at all possible, it is good practice to do this. If you cannot, you
+# will need to generate wheels for each Python version that you support.
+universal=1
+
+[nosetests]
+tests=roles/openshift_master_facts/test/, test/
+verbosity=2
+with-coverage=1
+cover-html=1
+cover-inclusive=1
+cover-min-percentage=70
+cover-erase=1
+detailed-errors=1
+cover-branches=1
+
+[yamllint]
+excludes=.tox,utils,files
+
+[lint]
+lint_disable=fixme,locally-disabled,file-ignored,duplicate-code
+
+[flake8]
+exclude=.tox/*,setup.py,utils/*,inventory/*
+max_line_length = 120
+ignore = E501,T003