summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorRussell Teague <rteague@redhat.com>2017-09-05 09:20:17 -0400
committerRussell Teague <rteague@redhat.com>2017-09-05 09:20:17 -0400
commit2907ea9e47c2d7e5243dbdf8f228ea5263f292af (patch)
tree614d97e9be2f64ae9e9d7efa770f1b85491fb75f /setup.py
parent2687979a5dd8df82b6843937e2bcc6a76b6b1668 (diff)
downloadopenshift-2907ea9e47c2d7e5243dbdf8f228ea5263f292af.tar.gz
openshift-2907ea9e47c2d7e5243dbdf8f228ea5263f292af.tar.bz2
openshift-2907ea9e47c2d7e5243dbdf8f228ea5263f292af.tar.xz
openshift-2907ea9e47c2d7e5243dbdf8f228ea5263f292af.zip
Fix ansible_syntax check
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index df2478ff9..c0c08b4d2 100644
--- a/setup.py
+++ b/setup.py
@@ -58,7 +58,7 @@ def find_entrypoint_playbooks():
os.path.join(os.getcwd(), 'playbooks'),
exclude_dirs, None, r'\.ya?ml$'):
with open(yaml_file, 'r') as contents:
- for task in yaml.safe_load(contents):
+ for task in yaml.safe_load(contents) or {}:
if not isinstance(task, dict):
# Skip yaml files which are not a dictionary of tasks
continue