summaryrefslogtreecommitdiffstats
path: root/utils/setup.py
diff options
context:
space:
mode:
authorRodolfo Carvalho <rhcarvalho@gmail.com>2017-02-19 14:42:33 +0100
committerRodolfo Carvalho <rhcarvalho@gmail.com>2017-02-20 18:12:04 +0100
commit1ac142fa1e785aade8272759d32561fc716e8740 (patch)
tree125fdfb17a10c19412f0921d2bec3951c293a7d4 /utils/setup.py
parented1c12c783e74f0226f33ba0a6f20cc6e5b5f396 (diff)
downloadopenshift-1ac142fa1e785aade8272759d32561fc716e8740.tar.gz
openshift-1ac142fa1e785aade8272759d32561fc716e8740.tar.bz2
openshift-1ac142fa1e785aade8272759d32561fc716e8740.tar.xz
openshift-1ac142fa1e785aade8272759d32561fc716e8740.zip
Replace nose with pytest (utils)
Diffstat (limited to 'utils/setup.py')
-rw-r--r--utils/setup.py7
1 files changed, 3 insertions, 4 deletions
diff --git a/utils/setup.py b/utils/setup.py
index 3518581e7..20e3d81dc 100644
--- a/utils/setup.py
+++ b/utils/setup.py
@@ -40,7 +40,7 @@ setup(
# simple. Or you can use find_packages().
#packages=find_packages(exclude=['contrib', 'docs', 'tests*']),
packages=['ooinstall'],
- package_dir={'ooinstall': 'src/ooinstall'},
+ package_dir={'': 'src'},
# List run-time dependencies here. These will be installed by pip when
@@ -65,9 +65,8 @@ setup(
'ooinstall': ['ansible.cfg', 'ansible-quiet.cfg', 'ansible_plugins/*'],
},
- tests_require=['nose'],
-
- test_suite='nose.collector',
+ setup_requires=['pytest-runner'],
+ tests_require=['pytest'],
# To provide executable scripts, use entry points in preference to the
# "scripts" keyword. Entry points provide cross-platform support and allow