summaryrefslogtreecommitdiffstats
path: root/roles/openshift_health_checker/openshift_checks/package_availability.py
Commit message (Collapse)AuthorAgeFilesLines
* Remove openshift.common.service_typeMichael Gugino2017-12-071-1/+3
| | | | | | | | This commit removes openshift.common.service_type in favor of openshift_service_type. This commit also removes r_openshift_excluder_service_type from plays in favor of using the role's defaults.
* openshift_checks: use oo group names everywhereLuke Meyer2017-10-041-2/+2
|
* openshift_checks: add retries in pythonLuke Meyer2017-09-121-1/+1
|
* openshift_checks: refactor to internalize task_varsLuke Meyer2017-07-251-8/+7
| | | | | | | | | Move task_vars into instance variable so we don't have to pass it around everywhere. Also store tmp. Make sure both are filled in on execute_module. In the process, is_active became an instance method, and task_vars is basically never used directly outside of test code.
* openshift_checks: improve comments/namesLuke Meyer2017-07-251-1/+5
|
* Rename cockpit-shell -> cockpit-systemRodolfo Carvalho2017-06-161-1/+1
| | | | | | | | The package name has changed. See https://bugzilla.redhat.com/show_bug.cgi?id=1461689 https://bugzilla.redhat.com/show_bug.cgi?id=1419718
* pre-install checks: add more during byo installLuke Meyer2017-06-141-2/+1
| | | | | | | | | | | | Add the docker and RPM checks to the list that run at install time. They can be disabled the same as the existing ones. Removed cockpit-kubernetes RPM requirement as it no longer is. Fixed up docker_image_availability to handle oreg_url and other nuances. Switched to using the openshift_image_tag that's set by openshift_version for both component and infrastructure images. Fixed a bug where execute_module was being called with incorrect positional arg "tmp" as a dict which caused errors down the call stack.
* skip PackageAvailability check if not yumjuanvallejo2017-04-111-0/+4
|
* Rename module_executor -> execute_moduleRodolfo Carvalho2017-03-281-1/+1
| | | | | | | | It is a function/callable, the name should imply action, should be a verb and not a noun. Keep supporting the old name while we have PRs in-flight that use the old name.
* Renamed NotContainerized to NotContainerizedMixin and dropped no-memberSteve Milner2017-02-221-2/+2
|
* Refactor code to access values from task_varsRodolfo Carvalho2017-02-101-7/+3
|
* Introduce tag notation for checksRodolfo Carvalho2017-02-101-0/+1
| | | | This allows us to refer to a group of checks using a single handle.
* Replace multi-role checks with action pluginRodolfo Carvalho2017-02-101-0/+69
This approach should make it easier to add new checks without having to write lots of YAML and doing things against Ansible (e.g. ignore_errors). A single action plugin determines what checks to run per each host, including arguments to the check. A check is implemented as a class with a run method, with the same signature as an action plugin and module, and is normally backed by a regular Ansible module. Each check is implemented as a separate Python file. This allows whoever adds a new check to focus solely in a single Python module, and potentially an Ansible module within library/ too. All checks are automatically loaded, and only active checks that are requested by the playbook get executed.