summaryrefslogtreecommitdiffstats
path: root/contrib/CMakeLists.txt
diff options
context:
space:
mode:
authorTomas Farago <sensej007@email.cz>2020-06-12 14:07:01 +0200
committerTomas Farago <sensej007@email.cz>2020-06-12 14:07:01 +0200
commit86c9551f08a28db25ff4966093114a92eb92f6bb (patch)
tree7d1560c06e42eaa54f4072168351dc186a4528cd /contrib/CMakeLists.txt
parentdb3cd886b8303a8a5aff20c76660ed49c2365f94 (diff)
downloadufo-filters-86c9551f08a28db25ff4966093114a92eb92f6bb.tar.gz
ufo-filters-86c9551f08a28db25ff4966093114a92eb92f6bb.tar.bz2
ufo-filters-86c9551f08a28db25ff4966093114a92eb92f6bb.tar.xz
ufo-filters-86c9551f08a28db25ff4966093114a92eb92f6bb.zip
Fix undefined CL_TARGET_OPENCL_VERSION warning
This is hardcoded to 120 (= OpenCL 1.2) because nvidia does not support later standards until 3.0 comes around and we do not make use of later features anyway.
Diffstat (limited to 'contrib/CMakeLists.txt')
-rw-r--r--contrib/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/contrib/CMakeLists.txt b/contrib/CMakeLists.txt
index 324cfeb..5566941 100644
--- a/contrib/CMakeLists.txt
+++ b/contrib/CMakeLists.txt
@@ -47,6 +47,7 @@ add_definitions("-std=c99 -Wall -fPIC")
add_definitions(-DG_LOG_DOMAIN="Ufo")
include_directories(${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
${OPENCL_INCLUDE_DIRS}
${UFO_INCLUDE_DIRS})
@@ -59,6 +60,10 @@ set(ufofilter_LIBS
${UFO_LIBRARIES}
${OpenCL_LIBRARIES})
+set(CL_TARGET_OPENCL_VERSION "120")
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/config.h.in
+ ${CMAKE_CURRENT_BINARY_DIR}/config.h)
+
# build static auxiliary library first
add_library(contrib_sxc_aux STATIC ${contrib_sxc_aux_SRCS})