summaryrefslogtreecommitdiffstats
path: root/contrib/CMakeLists.txt
diff options
context:
space:
mode:
authorTomas Farago <sensej007@email.cz>2020-08-14 13:38:27 +0200
committerTomas Farago <sensej007@email.cz>2020-08-14 13:38:50 +0200
commitca32b48afd4a49426275a5837a624727f12e23fc (patch)
tree208c1287641027ddf703f134dcc81b99dc8e4d22 /contrib/CMakeLists.txt
parent2444279f92dbc057ff503f8800a5aa98d11b5130 (diff)
downloadufo-filters-ca32b48afd4a49426275a5837a624727f12e23fc.tar.gz
ufo-filters-ca32b48afd4a49426275a5837a624727f12e23fc.tar.bz2
ufo-filters-ca32b48afd4a49426275a5837a624727f12e23fc.tar.xz
ufo-filters-ca32b48afd4a49426275a5837a624727f12e23fc.zip
Don't force non-dash task names
Diffstat (limited to 'contrib/CMakeLists.txt')
-rw-r--r--contrib/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/contrib/CMakeLists.txt b/contrib/CMakeLists.txt
index 5566941..10cfdc2 100644
--- a/contrib/CMakeLists.txt
+++ b/contrib/CMakeLists.txt
@@ -72,8 +72,7 @@ foreach(_src ${contrib_sxc_filter_SRCS})
string(REGEX REPLACE "ufo-([^ \\.]+)-task.*" "\\1" task "${_src}")
# build string to get miscalleanous sources
- string(REPLACE "-" "_" _misc ${task})
- string(TOUPPER ${_misc} _misc_upper)
+ set(target "ufofilter${task}")
# create an option name and add this to disable filters
set(_misc "${_misc}_misc_SRCS")