summaryrefslogtreecommitdiffstats
path: root/Wrappers/Python/recipe/meta.yaml
diff options
context:
space:
mode:
Diffstat (limited to 'Wrappers/Python/recipe/meta.yaml')
-rw-r--r--Wrappers/Python/recipe/meta.yaml43
1 files changed, 43 insertions, 0 deletions
diff --git a/Wrappers/Python/recipe/meta.yaml b/Wrappers/Python/recipe/meta.yaml
new file mode 100644
index 0000000..9d03220
--- /dev/null
+++ b/Wrappers/Python/recipe/meta.yaml
@@ -0,0 +1,43 @@
+package:
+ name: ccpi-framework
+ version: {{ environ['CIL_VERSION'] }}
+
+build:
+ preserve_egg_dir: False
+ script_env:
+ - CIL_VERSION
+ #number: 0
+
+test:
+ requires:
+ - python-wget
+ - cvxpy # [ unix and py36 and np115 ]
+
+ source_files:
+ - ./test # [win]
+ - ./ccpi/Wrappers/Python/test # [not win]
+
+ commands:
+ - python -c "import os; print (os.getcwd())"
+ - python -m unittest discover # [win]
+ - python -m unittest discover -s ccpi/Wrappers/Python/test # [not win]
+
+requirements:
+ build:
+ - {{ pin_compatible('numpy', max_pin='x.x') }}
+ - python
+ - setuptools
+
+ run:
+ - {{ pin_compatible('numpy', max_pin='x.x') }}
+ - python
+ - numpy
+ - scipy
+ - matplotlib
+ - h5py
+ - pillow
+
+about:
+ home: http://www.ccpi.ac.uk
+ license: Apache 2.0 License
+ summary: 'CCPi Framework'