summaryrefslogtreecommitdiffstats
path: root/dev-ruby/abstract_method/abstract_method-1.2.1.ebuild
diff options
context:
space:
mode:
authorSuren A. Chilingaryan <csa@suren.me>2019-10-24 02:09:32 +0200
committerSuren A. Chilingaryan <csa@suren.me>2019-10-24 02:09:32 +0200
commitdd2aea324c07fe1bd13143bb37eff11117b6130a (patch)
tree771ed8c8b9b1eb2f02b5843363eed86839ed6e5a /dev-ruby/abstract_method/abstract_method-1.2.1.ebuild
parent576b6208d6defe240bfa2477d6dd19f1ed83bfaf (diff)
downloaddarklin4-dd2aea324c07fe1bd13143bb37eff11117b6130a.tar.gz
darklin4-dd2aea324c07fe1bd13143bb37eff11117b6130a.tar.bz2
darklin4-dd2aea324c07fe1bd13143bb37eff11117b6130a.tar.xz
darklin4-dd2aea324c07fe1bd13143bb37eff11117b6130a.zip
Dice(kiwi) and dependencies; kiwi and dependecies (still missing zypper)
Diffstat (limited to 'dev-ruby/abstract_method/abstract_method-1.2.1.ebuild')
-rw-r--r--dev-ruby/abstract_method/abstract_method-1.2.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ruby/abstract_method/abstract_method-1.2.1.ebuild b/dev-ruby/abstract_method/abstract_method-1.2.1.ebuild
new file mode 100644
index 0000000..ab8775b
--- /dev/null
+++ b/dev-ruby/abstract_method/abstract_method-1.2.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+RUBY_FAKEGEM_EXTRAINSTALL="VERSION"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Abstract Method is a tiny library enabling you to define abstract methods in Ruby classes and modules."
+HOMEPAGE="https://rubygems.org/gems/abstract_method/"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+ruby_add_bdepend "
+ dev-ruby/rspec
+ dev-ruby/yard
+ dev-ruby/redcarpet
+"