summaryrefslogtreecommitdiffstats
path: root/media-plugins/xmms-mpg123/xmms-mpg123-1.2.10-r6.ebuild
diff options
context:
space:
mode:
authorSuren A. Chilingaryan <csa@suren.me>2019-09-01 00:00:32 +0200
committerSuren A. Chilingaryan <csa@suren.me>2019-09-01 00:00:32 +0200
commitca9627e70852f6b2e835660df870fe3ab405882d (patch)
tree0a008b1d5b16fa0679a195ed7b5662c7891f591c /media-plugins/xmms-mpg123/xmms-mpg123-1.2.10-r6.ebuild
downloaddarklin4-ca9627e70852f6b2e835660df870fe3ab405882d.tar.gz
darklin4-ca9627e70852f6b2e835660df870fe3ab405882d.tar.bz2
darklin4-ca9627e70852f6b2e835660df870fe3ab405882d.tar.xz
darklin4-ca9627e70852f6b2e835660df870fe3ab405882d.zip
Initial import
Diffstat (limited to 'media-plugins/xmms-mpg123/xmms-mpg123-1.2.10-r6.ebuild')
-rw-r--r--media-plugins/xmms-mpg123/xmms-mpg123-1.2.10-r6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-plugins/xmms-mpg123/xmms-mpg123-1.2.10-r6.ebuild b/media-plugins/xmms-mpg123/xmms-mpg123-1.2.10-r6.ebuild
new file mode 100644
index 0000000..6069426
--- /dev/null
+++ b/media-plugins/xmms-mpg123/xmms-mpg123-1.2.10-r6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sparc x86"
+IUSE="ipv6 ssl mmx 3dnow"
+
+DEPEND=">=media-sound/xmms-1.2.10-r12
+ ssl? ( dev-libs/openssl )"
+
+PLUGIN_PATH="Input/mpg123"
+
+M4_VER="1.1"
+PATCH_VER="2.2.6"
+RUSXMMS_VER="35"
+inherit rusxmms-plugin
+
+src_compile() {
+ myconf="${myconf} --enable-mpg123 $(use_enable ipv6) $(use_enable ssl)"
+
+ if use x86 && ! has_pic && { use mmx || use 3dnow; }; then
+ myconf="${myconf} --enable-simd"
+ else
+ myconf="${myconf} --disable-simd"
+ fi
+
+ rusxmms-plugin_src_compile
+}