summaryrefslogtreecommitdiffstats
path: root/app-dicts/slowo/slowo-1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-dicts/slowo/slowo-1.0.ebuild')
-rw-r--r--app-dicts/slowo/slowo-1.0.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/app-dicts/slowo/slowo-1.0.ebuild b/app-dicts/slowo/slowo-1.0.ebuild
deleted file mode 100644
index a73e1a4..0000000
--- a/app-dicts/slowo/slowo-1.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit eutils
-
-DESCRIPTION="Slowo Dictionary"
-SRC_URI="http://dside.dyndns.org/files/darklin/slowo.tar.bz2"
-SLOT="0"
-
-KEYWORDS="x86 amd64"
-LICENSE="GPL-2"
-IUSE="X"
-
-FONT_ROOT=/usr/share/fonts/DarkLin
-
-DEPEND="sys-libs/ncurses
- X? ( x11-base/xorg-x11 )"
-
-src_compile() {
- cd ${WORKDIR}
-
- cd slowo || die
- make
-# cd ../sortbase || die
-# make
-
- if use X ; then
- cd ../xslowo
- make
-# cd ../qtslowo
-# make
- fi
-}
-
-src_install() {
- cd ${WORKDIR}
-
- mkdir -p ${D}/usr/bin
- mkdir -p ${D}/${FONT_ROOT}
-
- install -c -m 755 slowo/slowo ${D}/usr/bin/slowo
-# install -c -m 755 sortbase/slowosort ${D}/usr/bin/slowosort
- cp -rf dwa ${D}/usr/share
-
- if use X ; then
- install -c -m 755 xslowo/slowo ${D}/usr/bin/xslowo
-# install -c -m 755 qtslowo/slowo ${D}/usr/bin/qtslowo
- fi
-
- cp -rf IPAFonts ${D}/${FONT_ROOT}
-}
-
-pkg_postinst() {
- einfo "In order to make X see the fonts, you need to add the"
- einfo "following lines to the files section of your "
- einfo "/etc/X11/XF86Config (or the XOrg equivalent):"
- einfo " FontPath \"${FONT_ROOT}/DarkLin/IPAFonts:unscaled\""
-}