summaryrefslogtreecommitdiffstats
path: root/dev-ruby/dice/dice-0.7.10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/dice/dice-0.7.10.ebuild')
-rw-r--r--dev-ruby/dice/dice-0.7.10.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-ruby/dice/dice-0.7.10.ebuild b/dev-ruby/dice/dice-0.7.10.ebuild
new file mode 100644
index 0000000..0cc0a03
--- /dev/null
+++ b/dev-ruby/dice/dice-0.7.10.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+#inherit ruby-fakegem git-r3
+#inherit cmake-utils
+inherit eutils multilib ruby-fakegem git-r3
+
+
+DESCRIPTION="OpenSuSE Dice for KIWI images"
+HOMEPAGE="https://github.com/OSInside/dice"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/OSInside/dice.git"
+EGIT_CHECKOUT_DIR="${WORKDIR}/all"
+EGIT_BRANCH="master"
+
+QA_PREBUILT="usr/lib*/ruby/gems/*/gems/${P}/lib/semaphore/sempahore.so"
+
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+ruby_add_rdepend "
+ dev-ruby/gli
+ dev-libs/libsolv[ruby,rpm]
+"
+
+ruby_add_bdepend "
+ dev-ruby/abstract_method
+ dev-ruby/bundler
+ dev-ruby/inifile
+ dev-ruby/json
+ dev-ruby/cheetah
+ dev-ruby/rice
+"
+
+
+each_ruby_configure() {
+ ${RUBY} -rrubygems -Clib/semaphore extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Clib/semaphore V=1
+ rm -f lib/semaphore/*.o
+}
+