summaryrefslogtreecommitdiffstats
path: root/dev-ruby/rice/rice-2.1.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rice/rice-2.1.3.ebuild')
-rw-r--r--dev-ruby/rice/rice-2.1.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/rice/rice-2.1.3.ebuild b/dev-ruby/rice/rice-2.1.3.ebuild
new file mode 100644
index 0000000..4f8d94c
--- /dev/null
+++ b/dev-ruby/rice/rice-2.1.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+inherit ruby-fakegem
+RUBY_FAKEGEM_EXTRAINSTALL="ruby"
+
+DESCRIPTION="Rice is a C++ interface to Ruby's C API. It provides a type-safe and exception-safe interface in order to make embedding Ruby and writing Ruby extensions with C++ easier. It is similar to Boost.Python in many ways, but also attempts to provide an object-oriented interface to all of the Ruby C API."
+HOMEPAGE="https://rubygems.org/gems/rice/"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+
+each_ruby_prepare() {
+ ${RUBY} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake || die
+ find . -name *.o -delete
+}
+
+each_ruby_install() {
+ emake install || die
+ each_fakegem_install
+}