summaryrefslogtreecommitdiffstats
path: root/net-analyzer/gnu-netcat/gnu-netcat-0.7.1-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/gnu-netcat/gnu-netcat-0.7.1-r3.ebuild')
-rw-r--r--net-analyzer/gnu-netcat/gnu-netcat-0.7.1-r3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-analyzer/gnu-netcat/gnu-netcat-0.7.1-r3.ebuild b/net-analyzer/gnu-netcat/gnu-netcat-0.7.1-r3.ebuild
new file mode 100644
index 0000000..7d2707d
--- /dev/null
+++ b/net-analyzer/gnu-netcat/gnu-netcat-0.7.1-r3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/gnu-netcat/gnu-netcat-0.7.1-r3.ebuild,v 1.8 2013/02/17 23:20:20 zmedico Exp $
+
+EAPI="6"
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="the GNU network swiss army knife"
+HOMEPAGE="http://netcat.sourceforge.net/"
+SRC_URI="mirror://sourceforge/netcat/netcat-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~hppa ppc sparc x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug nls"
+
+S=${WORKDIR}/netcat-${PV}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-flagcount.patch \
+ "${FILESDIR}"/${PN}-close.patch \
+ "${FILESDIR}"/${PN}-LC_CTYPE.patch
+
+}
+
+src_configure() {
+ use debug && append-flags -DDEBUG
+ econf $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ rm "${ED}"usr/bin/nc
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}