summaryrefslogtreecommitdiffstats
path: root/x11-terms/xterm/xterm-278-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/xterm/xterm-278-r1.ebuild')
-rw-r--r--x11-terms/xterm/xterm-278-r1.ebuild110
1 files changed, 0 insertions, 110 deletions
diff --git a/x11-terms/xterm/xterm-278-r1.ebuild b/x11-terms/xterm/xterm-278-r1.ebuild
deleted file mode 100644
index 63a1bd9..0000000
--- a/x11-terms/xterm/xterm-278-r1.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/xterm/xterm-278.ebuild,v 1.1 2012/01/19 19:01:38 ssuominen Exp $
-
-EAPI=4
-inherit eutils multilib
-
-DESCRIPTION="Terminal Emulator for X Windows"
-HOMEPAGE="http://dickey.his.com/xterm/"
-SRC_URI="ftp://invisible-island.net/${PN}/${P}.tgz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="toolbar truetype unicode Xaw3d"
-
-COMMON_DEPEND="kernel_linux? ( sys-libs/libutempter )
- kernel_FreeBSD? ( sys-libs/libutempter )
- >=sys-libs/ncurses-5.7-r7
- x11-apps/xmessage
- x11-libs/libX11
- x11-libs/libXaw
- x11-libs/libXft
- x11-libs/libxkbfile
- x11-libs/libXmu
- x11-libs/libXrender
- x11-libs/libXt
- unicode? ( x11-apps/luit )
- Xaw3d? ( x11-libs/libXaw3d )"
-RDEPEND="${COMMON_DEPEND}
- media-fonts/font-misc-misc"
-DEPEND="${COMMON_DEPEND}
- dev-util/pkgconfig
- x11-proto/kbproto
- x11-proto/xproto"
-
-pkg_setup() {
- DEFAULTS_DIR="${EPREFIX}"/usr/share/X11/app-defaults
-}
-
-#SDS
-src_unpack() {
- unpack ${A}
- cd ${S}
-
-#MDK
-# epatch ${FILESDIR}/xterm-199-biarch-utmp.patch.bz2
-# epatch ${FILESDIR}/xterm-197-alt-keysym-index.patch.bz2
-# epatch ${FILESDIR}/xterm-199-alt-meta-mod.patch.bz2
-
-#DarkLin
- epatch ${FILESDIR}/xterm-ds-config-278.patch || die
- epatch ${FILESDIR}/xterm-ds-paste-278.patch || die
- epatch ${FILESDIR}/xterm-ds-input-225.patch || die
- epatch ${FILESDIR}/xterm-ds-copy-243.patch || die
-# Embedded in SM patch
-## epatch ${FILESDIR}/xterm-ds-utf8mode.patch
-# Since 278 is provided internaly
-## epatch ${FILESDIR}/xterm-ds-sm-243.patch || die
-# Incorporated into the config patch
-## epatch ${FILESDIR}/xterm-ds-metaesc.patch || die
-}
-#EDS
-
-src_configure() {
- # looking for reason why crosscompile failed? try restoring this:
- # --x-libraries="${ROOT}usr/$(get_libdir)"
- # -ssuominen, 2011
-
- econf \
- --libdir="${EPREFIX}"/etc \
- --disable-full-tgetent \
- --with-app-defaults=${DEFAULTS_DIR} \
- --disable-setuid \
- --disable-setgid \
- --with-utempter \
- --with-x \
- $(use_with Xaw3d) \
- --disable-imake \
- --enable-256-color \
- --enable-broken-osc \
- --enable-broken-st \
- --enable-exec-xterm \
- $(use_enable truetype freetype) \
- --enable-i18n \
- --enable-load-vt-fonts \
- --enable-logging \
- $(use_enable toolbar) \
- $(use_enable unicode mini-luit) \
- $(use_enable unicode luit) \
- --enable-wide-chars \
- --enable-dabbrev \
- --enable-warnings
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc README{,.i18n} ctlseqs.txt
- dohtml xterm.log.html
- domenu *.desktop
-
- # Fix permissions -- it grabs them from live system, and they can
- # be suid or sgid like they were in pre-unix98 pty or pre-utempter days,
- # respectively (#69510).
- # (info from Thomas Dickey) - Donnie Berkholz <spyderous@gentoo.org>
- fperms 0755 /usr/bin/xterm
-
- # restore the navy blue
- sed -i -e "s:blue2$:blue:" "${ED}"${DEFAULTS_DIR}/XTerm-color
-}