summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Dockerfile5
-rw-r--r--Makefile28
2 files changed, 17 insertions, 16 deletions
diff --git a/Dockerfile b/Dockerfile
index a32229e..d235c7a 100644
--- a/Dockerfile
+++ b/Dockerfile
@@ -1,4 +1,5 @@
-FROM gentoo/stage3-amd64:20190829
+FROM gentoo/stage3:amd64
+#FROM gentoo/stage3:amd64-20201121
RUN emerge --sync && \
emerge -1 portage
@@ -7,7 +8,7 @@ RUN emerge --sync && \
# echo 'PYTHON_TARGETS="${PYTHON_TARGETS} python3_6"' >> /etc/portage/make.conf && \
# echo 'PYTHON_SINGLE_TARGET="python3_6"' >> /etc/portage/make.conf
-RUN emerge =gcc-8.3.0* distcc
+RUN emerge =gcc-9.3.0* distcc
RUN ( \
echo "#!/bin/sh" && \
diff --git a/Makefile b/Makefile
index ba48592..c74e2a4 100644
--- a/Makefile
+++ b/Makefile
@@ -4,29 +4,29 @@ install: push
.PHONY: rebuild build push start stop restart bash logs
build: Dockerfile
- docker build --tag chsa/distcc:latest .
+ podman build --cap-add=CAP_SYS_PTRACE --tag chsa/distcc:latest .
rebuild: Dockerfile
- docker build --no-cache --tag chsa/distcc:latest .
+ podman build --no-cache --cap-add=CAP_SYS_PTRACE --tag chsa/distcc:latest .
push: build
- docker push chsa/distcc:latest
+ podman push chsa/distcc:latest
start: build
- if [ `docker ps | grep chsa/distcc | wc -l` -eq 0 ]; then \
- if [ `docker ps -a | grep distccd | wc -l` -gt 0 ]; then \
+ if [ `podman ps | grep chsa/distcc | wc -l` -eq 0 ]; then \
+ if [ `podman ps -a | grep distccd | wc -l` -gt 0 ]; then \
echo "Removing the stalled copy..." ;\
- docker rm distccd ;\
+ podman rm distccd ;\
fi ;\
- docker run -p 0.0.0.0:3632:3632 --name distccd -t -d chsa/distcc:latest ;\
+ podman run -p 0.0.0.0:3632:3632 --name distccd -t -d chsa/distcc:latest ;\
else \
echo "Already running..." ;\
fi
stop:
- @if [ `docker ps | grep distccd | wc -l` -gt 0 ]; then \
- docker stop distccd ;\
- docker rm distccd ;\
+ @if [ `podman ps | grep distccd | wc -l` -gt 0 ]; then \
+ podman stop distccd ;\
+ podman rm distccd ;\
fi
restart:
@@ -34,12 +34,12 @@ restart:
make start
debug: build
- docker rm distccd ;\
- docker run -p 0.0.0.0:3632:3632 --name distccd -it chsa/distcc:latest /bin/bash
+ podman rm distccd ;\
+ podman run -p 0.0.0.0:3632:3632 --name distccd -it chsa/distcc:latest /bin/bash
bash: build
- docker exec -it distccd /bin/bash
+ podman exec -it distccd /bin/bash
logs:
- docker logs distccd
+ podman logs distccd