summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 17f504b..1a71607 100644
--- a/configure.in
+++ b/configure.in
@@ -84,7 +84,16 @@ AC_SUBST(XML_INCLUDES)
dnl ***
dnl *** GTK1 (Optional)
dnl ***
-AC_PATH_PROG(GTK_CONFIG, gtk-config, no)
+AC_ARG_ENABLE(gtk1,
+ [ --disable-gtk1 disable gtk1 [default=enabled]],,
+ enable_gtk1="yes")
+
+if test "x$enable_gtk1" = "xyes"; then
+ AC_PATH_PROG(GTK_CONFIG, gtk-config, no)
+else
+ GTK_CONFIG="no"
+fi
+
if test $GTK_CONFIG = no; then
HAVE_GTK=no
else