summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8817d6b..4baa8a3 100644
--- a/configure.in
+++ b/configure.in
@@ -136,6 +136,22 @@ else
fi
AM_CONDITIONAL(HAVE_GTK2, [ test $HAVE_GTK2 = yes ])
+
+dnl ***
+dnl *** GTK 3.0 (Optional)
+dnl ***
+AC_ARG_ENABLE(gtk3,
+ [ --disable-gtk3 disable gtk3 [default=enabled]],,
+ enable_gtk3="yes")
+
+if test "x$enable_gtk3" = "xyes"; then
+ PKG_CHECK_MODULES(GTK3, gtk+-3.0 >= 3.0.0, HAVE_GTK3=yes, HAVE_GTK3=no)
+else
+ HAVE_GTK3=no
+fi
+AM_CONDITIONAL(HAVE_GTK3, [ test $HAVE_GTK3 = yes ])
+
+
dnl ***
dnl *** Shared libraries support
dnl ***
@@ -407,6 +423,7 @@ echo ""
echo "User Interfaces:"
echo " GTK User Interface: $HAVE_GTK"
echo " GTK2 User Interface: $HAVE_GTK2"
+echo " GTK3 User Interface: $HAVE_GTK3"
echo ""
echo "Directories:"
echo " RCC Data Directory: ${rccdir}"