summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..3738ce1
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,11 @@
+cmake_minimum_required(VERSION 2.6.3)
+project(librcd)
+
+set(CMAKE_BUILD_TYPE RELEASE)
+
+if (NOT WIN32)
+ message(FATAL_ERROR "Windows only, use autotools to build under POSIX-capable systems")
+endif(NOT WIN32)
+
+add_subdirectory(src)
+