summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorSuren A. Chilingaryan <csa@dside.dyndns.org>2007-04-15 01:10:43 +0000
committerSuren A. Chilingaryan <csa@dside.dyndns.org>2007-04-15 01:10:43 +0000
commit18fe60be6c1ab65e4407a1d9681adc6e153d61c6 (patch)
treece889a24531af094974df5f532b93e4f0634f270 /configure.in
downloadrcc-tools-18fe60be6c1ab65e4407a1d9681adc6e153d61c6.tar.gz
rcc-tools-18fe60be6c1ab65e4407a1d9681adc6e153d61c6.tar.bz2
rcc-tools-18fe60be6c1ab65e4407a1d9681adc6e153d61c6.tar.xz
rcc-tools-18fe60be6c1ab65e4407a1d9681adc6e153d61c6.zip
initial import
(automatically generated log message)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..be5de78
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,25 @@
+AC_INIT(rcc-recode.c)
+AM_INIT_AUTOMAKE(rcc_tools, `cat VERSION | sed -e s/CVS//`)
+AC_CONFIG_HEADERS(config.h)
+
+AC_PROG_CC
+AC_PROG_INSTALL
+AM_PROG_LIBTOOL
+
+AC_CHECK_HEADERS(getopt.h dirent.h sys/types.h sys/file.h sys/stat.h)
+
+AC_CHECK_HEADER(librcc.h,
+ [AC_CHECK_LIB(rcc, rccInit,
+ [
+ AC_DEFINE(HAVE_LIBRCC,1,[Defines if librcc is available])
+ ],[
+ AC_MSG_ERROR(LibRCC is required)
+ ])
+ ],[
+ AC_MSG_ERROR(LibRCC is required)
+
+ ])
+
+AC_OUTPUT([
+ Makefile
+])