summaryrefslogtreecommitdiffstats
path: root/src/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build26
1 files changed, 15 insertions, 11 deletions
diff --git a/src/meson.build b/src/meson.build
index 5bd5509..2a3f8da 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -43,17 +43,21 @@ lib = library('uca',
install: true,
)
-gnome.generate_gir(lib,
- namespace: 'Uca',
- nsversion: '@0@.0'.format(version_major),
- sources: sources + headers,
- install: true,
- includes: [
- 'GLib-2.0',
- 'GObject-2.0',
- 'GModule-2.0',
- ],
-)
+gir = find_program('g-ir-scanner', required: false)
+
+if gir.found() and get_option('introspection')
+ gnome.generate_gir(lib,
+ namespace: 'Uca',
+ nsversion: '@0@.0'.format(version_major),
+ sources: sources + headers,
+ install: true,
+ includes: [
+ 'GLib-2.0',
+ 'GObject-2.0',
+ 'GModule-2.0',
+ ],
+ )
+endif
pkg = import('pkgconfig')