summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2013-10-29 09:05:51 +0100
committerMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2013-10-29 09:05:51 +0100
commit137f03b9a34fb39e5321524ab11fa31276458476 (patch)
tree83ea6e2b2228d1e99a37a0e510faaa13130ef849 /CMakeLists.txt
parent85a0f33711fd4467b9027da85ab9e09e406398d4 (diff)
downloaduca-137f03b9a34fb39e5321524ab11fa31276458476.tar.gz
uca-137f03b9a34fb39e5321524ab11fa31276458476.tar.bz2
uca-137f03b9a34fb39e5321524ab11fa31276458476.tar.xz
uca-137f03b9a34fb39e5321524ab11fa31276458476.zip
Use ConfigurePaths to get installation paths
The advantage is twofold: 1) we have a clear separation between setting up the paths and actually using them, 2) the interface is very likely as configure scripts and makes integration into build system a bit easier.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 25c07e3..6c5ede2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -66,11 +66,14 @@ macro(create_enums prefix template_prefix header_list)
endmacro()
#}}}
#{{{ Configure
+include(ConfigurePaths)
+configure_paths(UCA)
+
+set(UCA_PLUGINDIR "${UCA_LIBDIR}/uca")
set(LIB_INSTALL_DIR "lib${LIB_SUFFIX}")
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/package.sh.in
${CMAKE_CURRENT_BINARY_DIR}/package.sh)
-
#}}}
#{{{ Common dependencies
find_package(PkgConfig)