summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMihael Koep <koep@schneide.com>2012-10-30 18:21:05 +0100
committerMihael Koep <koep@schneide.com>2012-10-30 18:21:05 +0100
commit7bd33f1eb88ce537e21693a805390d6385e43b80 (patch)
treec87bbe607202050370a31943f1280a2864bae4eb /CMakeLists.txt
parent4245ad0b8d12574a3c2c15bd057246065e5026ca (diff)
downloaduca-7bd33f1eb88ce537e21693a805390d6385e43b80.tar.gz
uca-7bd33f1eb88ce537e21693a805390d6385e43b80.tar.bz2
uca-7bd33f1eb88ce537e21693a805390d6385e43b80.tar.xz
uca-7bd33f1eb88ce537e21693a805390d6385e43b80.zip
Include CPack in the build process and set the package file name correctly.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e9d49fa..6856df1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,6 +22,7 @@ set(CPACK_DEBIAN_PACKAGE_NAME "libuca")
set(CPACK_DEBIAN_PACKAGE_MAINTAINER "Matthias Vogelgesang <matthias.vogelgesang@kit.edu>")
set(CPACK_DEBIAN_PACKAGE_DESCRIPTION ${UCA_DESCRIPTION})
set(CPACK_DEBIAN_PACKAGE_DESCRIPTION_SUMMARY ${UCA_DESCRIPTION})
+set(CPACK_PACKAGE_FILE_NAME "${PACKAGE_NAME}-${PACKAGE_VERSION}-${CPACK_PACKAGE_RELEASE}.${CMAKE_SYSTEM_PROCESSOR}")
set(CPACK_DEBIAN_PACKAGE_ARCHITECTURE "amd64")
@@ -72,3 +73,6 @@ add_subdirectory(src)
add_subdirectory(plugins)
add_subdirectory(test)
add_subdirectory(tools)
+
+include(CPack)
+