summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSuren A. Chilingaryan <csa@dside.dyndns.org>2013-11-16 00:35:49 +0100
committerSuren A. Chilingaryan <csa@dside.dyndns.org>2013-11-16 00:35:49 +0100
commitf5dde7a5996d7034924916de6413cd1411d7a5fc (patch)
tree3a2d82fa882d3926440ab5b61e305418fcd63177 /Makefile.am
parentb5c156f376d1cf3227c7a18a670bac62aa7f9622 (diff)
downloadlibrcc-f5dde7a5996d7034924916de6413cd1411d7a5fc.tar.gz
librcc-f5dde7a5996d7034924916de6413cd1411d7a5fc.tar.bz2
librcc-f5dde7a5996d7034924916de6413cd1411d7a5fc.tar.xz
librcc-f5dde7a5996d7034924916de6413cd1411d7a5fc.zip
Multiple fixes of build system
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 12 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index f0901f2..582a1ba 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,11 +1,20 @@
SUBDIRS = src engines external ui
-EXTRA_DIST = librcd.spec
+DIST_SUBDIRS = ${SUBDIRS} examples
+EXTRA_DIST = librcc.spec
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = librcc.pc
ACLOCAL_AMFLAGS = -I m4
-clean-local:
- make -C examples clean
+@SET_MAKE@
+
+.PHONY: examples
+examples:
+ ${MAKE} -C examples
+
+clean-local:
+ if [ -f examples/Makefile ]; then\
+ ${MAKE} -C examples clean;\
+ fi