summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 12 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index f0901f2..582a1ba 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,11 +1,20 @@
SUBDIRS = src engines external ui
-EXTRA_DIST = librcd.spec
+DIST_SUBDIRS = ${SUBDIRS} examples
+EXTRA_DIST = librcc.spec
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = librcc.pc
ACLOCAL_AMFLAGS = -I m4
-clean-local:
- make -C examples clean
+@SET_MAKE@
+
+.PHONY: examples
+examples:
+ ${MAKE} -C examples
+
+clean-local:
+ if [ -f examples/Makefile ]; then\
+ ${MAKE} -C examples clean;\
+ fi